X10 Hoverboard

Back In Stock
6 Reviews JX10-BLK
Choose your Color
Black
Blue
Gray
Red
Rose Gold
X10 Hoverboard
$229.99
Free shipping on orders over $100
Max Speed
Up to 10 mph

Max Range
Up to 12 miles

Climbing Angle
15 degrees

Product Weight
19.65 lbs

Weight Limit
265 lbs

Motor
500 watt dual hub motor

Battery
25.9V, 4.0Ah lithium-ion

Wheels
6.5"

Tires
Extreme terrain tires

Active Balance Technology
Yes

UL 2272
UL 2272 safety standards certified

Lights
LED front and light up wheels

Charging Time
Up to 3 hours

Bluetooth
Yes

Speaker
Yes

Product Dimensions (L x W x H)
24.5" x 7.5" x 7"

Recommended Age
12 and up

Assembly Required
No

Warranty
1 year limited

Customer Reviews

5 Based on 6 Reviews
5 ★
100% 
6
4 ★
0% 
0
3 ★
0% 
0
2 ★
0% 
0
1 ★
0% 
0
Write a Review Ask a Question
  • Reviews
  • Questions

Thank you for submitting a review!

Your input is very much appreciated. Share it with your friends so they can enjoy it too!

Filter Reviews:
  • wheel
  • Christmas
  • daughter
  • neighborhood
  • Bluetooth
  • company
  • side
  • hoverboard
  • features
  • ride
C
01/01/2020
Cannon
United States United States

Awesome, Sweet, Epic!!!!!

Fantastic!!!!!!

JD
12/01/2019
Johnny D.
United States United States

The Best.

The Best.

JJ
03/19/2019
James J.

Great product.

Hoverboard was great had an iddue with the right wheel and contacted Jetson. The customer support and help has been fantastic! Great company that stands behind their products!

F
03/19/2019
Frank

Excellent product

Excellent product

E
03/19/2019
Erin

Fits the bill!

My daughter received the 10x All-Terrain Hoverboard for Christmas and it was a hit with all the kids! Besides the smooth ride, she loved the light features and the Bluetooth radio she could sync to her iPod. I wanted a hover board that could be ridden in our backyard because we do not have sidewalks in our neighborhood. I will confirm it does works in the grass! Only thing I question is the battery, one side starts blinking before the other, so I’m not sure if this is a user error, or normal, I haven’t been able to call customer support to figure this out.